Перейти к содержанию

MikroTik RB750 — настройка BGP

Статическая маршрутизация — это не всегда гуд. А когда аплинков больше одного — еще и насущная необходимость. Желающих прошу под кат

Первым делом лезем в ман.

Ну и делаем то, что нам нужно:

/routing bgp instance
set default as=64813 client-to-client-reflection=yes comment="" disabled=no
    ignore-as-path-len=no name=default out-filter="" redistribute-connected=
    yes redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no
    redistribute-static=yes router-id=11.22.33.55 routing-table=""

Собственно, создаем BGP-инстанс, указываем автономку (у нас серая) и router-id (если указали router-id, то этот адрес будет анонситься и пинговаться, хотя интерфейса вроде бы нет) Говорим, что будем отдавать только connected и static-маршруты, и не ретранслировать то, что будет прилетать к нам по bgp и ospf.

Т.к. у Mikrotik нет интерфейса lo, как такового, так что loopback вешаем на интерфейс bridgelo:

/interface bridge add name=bridgelo
ip address add address=11.22.33.55/32 interface=bridgelo
/routing bgp peer
add address-families=ip as-override=no comment="" default-originate=never
    disabled=no hold-time=3m in-filter="" instance=default multihop=no name=
    router.main nexthop-choice=default out-filter="" passive=no
    remote-address=11.22.33.43 remote-as=65001 remove-private-as=no
    route-reflect=no tcp-md5-key="" ttl=default use-bfd=no
add address-families=ip as-override=no comment="" default-originate=never
    disabled=no hold-time=3m in-filter=RES-IN instance=default multihop=no
    name=router.backup nexthop-choice=default out-filter=RES-OUT passive=no
    remote-address=11.22.34.43 remote-as=65002 remove-private-as=no
    route-reflect=no tcp-md5-key="" ttl=255 use-bfd=no

Создаем сессии — основную и резервную. Единственное отличие — фильтр (он же prefix-list и route-map в одном лице)

/routing filter
add action=accept bgp-as-path="^$" chain=RES-OUT comment="" disabled=no
    invert-match=no set-bgp-prepend=3 set-bgp-prepend-path=
add action=discard chain=RES-OUT comment="" disabled=no invert-match=no
add action=accept chain=RES-IN comment="" disabled=no invert-match=no
    set-bgp-prepend=3 set-bgp-prepend-path=

Самое вкусное:
1. Отдаем только «свои» сети (т.е. которые прописаны непосредственно на маршрутизаторе). Дополняет пункт «redistribute-other-bgp»
2. set-bgp-prepend=3 set-bgp-prepend-path= задает препенд, с которым мы будем отдавать маршруты резервному роутеру (на прием то же самое)

На этом базовая настройка закончена, в принципе, в 95% случаев этого хватит с головой.

2 комментария

  1. xapmc xapmc

    Здравствуйте.
    Интересует возможность black hole-ть маршруты с префиксом /32
    Как это можно сделать на mikrotic CCR серии ?
    Благодарю.

  2. admin admin

    Ровно также, как и на других микротиках:

    1
    2
    /routing filter add prefix=10.0.0.0/8 prefix-length=8-32 set-type=blackhole chain=myfilter
    /ip route add dst-address=10.0.0.0/8 type=blackhole

Добавить комментарий

%d такие блоггеры, как: