Перейти к содержанию

Установка драйверов NVIDIA в Debian Squeeze

Накатынные при установке дебиана дрова после перезагрузке отказались стартовать, так что пришлось лезть на сайт нвидии и качать новые. (Да, я знаю про репозитории, но это же дебиан, т.е. версия там уж больно лохматая). После недолгого гуглежа набрел на следующее

root@linux# aptitude install nvidia-glx nvidia-kernel-dkms nvidia-settings nvidia-vdpau-driver.
root@linux# nvidia-xconfig


Если же используется самосборное ядро или установлен testing или unstable дистрибутив, то придется воспользоваться module-assistant:

root@linux# aptitude install module-assistant
root@linux# module-assistant prepare
root@linux# module-assistant update
root@linux# module-assistant auto-install nvidia-kernel-source
root@linux# nvidia-xconfig

Для поддержки аппаратного ускорения в 32-битных программах нужно установить пакет nvidia-glx-ia32.

Быстрый (хоть и идеологически неверный) вариант

sgfxi это автоматический инсталлятор и конфигуратор видеодрайверов для nvidia, ati/amd, а также свободных драйверов из состава Xorg для Debian (с некоторых пор добавлена поддержка Ubuntu и Arch). При каждом запуске скрипт автоматически обновляется, что позволяет с большой долей вероятности получить работоспособные драйвера даже для самых свежих ядер.

скачиваем:
$wget http://sgfxi.googlecode.com/svn/trunk/sgfxi
#делаем исполняемым:
$chmod +x sgfxi
#гасим иксы (внимательно изучив справку можно обойтись и без этого,
#но в любом случае их придётся перезагружать):
$sudo init 3
#запускаем:
$sudo ./sgfxi

Скрипт проверит актуальность своей версии, обновится при необходимости, выяснит модель видеокарты, версию ядра, установит необходимые пакеты, применит патчи и соберет библиотеки и модули. Если все пройдет успешно — сам предложит запустить иксы.

Думаете, все? Щазз… apt начинает ругаться благим матом при попытке установить какой-нибудь пакет:

E: Sub-process /usr/bin/dpkg returned an error code (1)
Ошибка при установке пакета. Попытка восстановления:
Настраивается пакет libgl1-nvidia-alternatives (195.36.31-6) ...
Оставляется «отклонение /usr/lib/libGL.so в /usr/lib/nvidia/diversions/libGL.so из-за libgl1-nvidia-alternatives»
Оставляется «отклонение /usr/lib/libGL.so.1 в /usr/lib/nvidia/diversions/libGL.so.1 из-за libgl1-nvidia-alternatives»
Оставляется «отклонение /usr/lib/libGL.so.1.2 в /usr/lib/nvidia/diversions/libGL.so.1.2 из-за libgl1-nvidia-alternatives»
Обрабатываются триггеры для libgl1-nvidia-alternatives ...
update-alternatives: ошибка: альтернативный путь /usr/lib/nvidia/diversions/libGL.so.1 не существует.
dpkg: не удалось обработать параметр libgl1-nvidia-alternatives (--configure):
подпроцесс установлен сценарий post-installation возвратил код ошибки 2
При обработке следующих пакетов произошли ошибки:
libgl1-nvidia-alternatives

Лечится просто — переустановкой libgl1-mesa-glx:

root@linux# aptitude reinstall libgl1-mesa-glx

Один комментарий

  1. mihail mihail

    ООО! пасиб!!! статья гуд. коротко и понятно

Добавить комментарий для mihail Отменить ответ

%d такие блоггеры, как: